ABAQUS/CAE: FSI

classic Classic list List threaded Threaded
15 messages Options
Reply | Threaded
Open this post in threaded view
|

ABAQUS/CAE: FSI

priyanshu
This post has NOT been accepted by the mailing list yet.
I am modelling a FSI problem. Following a similar tutorial for my problem , when i am solving my problem, it is displaying this error for my solid model
" Director terminated the analysis due to early termination by a client. Please check for errors for each of the analysis involved in co-simulation and also verify that the co-simulation duration time specified in the configuration file is correct."
and this error for my fluid domain
"An unrecoverable co-simulation error has been encountered.

The executable SMACfdMain.exe aborted with system error code 3. Please check the .dat, .msg, and .sta files for error messages if the files exist.  If there are no error messages and you cannot resolve the problem, please run the command "abaqus job=support information=support" to report and save your system information.  Use the same command to run Abaqus that you used when the problem occurred.  Please contact your local Abaqus support office and send them the input file, the file support.log which you just created, the executable name, and the error code."

Kindlt please guide, as i m unable to understand this error.
Reply | Threaded
Open this post in threaded view
|

Re: ABAQUS/CAE: FSI

ftastisch
This post has NOT been accepted by the mailing list yet.
Hi!

I'm running into the same problem. Did you find out how to fix it?
Reply | Threaded
Open this post in threaded view
|

Re: ABAQUS/CAE: FSI

priyanshu
This post has NOT been accepted by the mailing list yet.
hi... ftastisch
1. See whether you the two models (Solid and CDF) are in proper position.. 
2. See mesh type and size
3  Try to run simulation for shorter step time 
4 Check BC's

Positioning might solve the issue

Priyanshu Sharma 
ME-DESIGN, BITS PILANI, HYDERABAD
AP-500078


On Tue, Jul 22, 2014 at 8:41 PM, ftastisch [via Abaqus Users] <[hidden email]> wrote:
Hi!

I'm running into the same problem. Did you find out how to fix it?


If you reply to this email, your message will be added to the discussion below:
http://abaqus-users.1086179.n5.nabble.com/ABAQUS-CAE-FSI-tp21070p21561.html
To unsubscribe from ABAQUS/CAE: FSI, click here.
NAML

Reply | Threaded
Open this post in threaded view
|

Re: ABAQUS/CAE: FSI

mitenp
This post was updated on .
CONTENTS DELETED
The author has deleted this message.
Reply | Threaded
Open this post in threaded view
|

Re: ABAQUS/CAE: FSI

mitenp
This post has NOT been accepted by the mailing list yet.
Hi,

I've just installed v6.13 on home PC to enable VPN access to college license server.   I got the same error while trying to solve the fluid-structure example E.1 Flow through  a bent tube from the Abacus documentation.

Assuming this might be a memory issue based on some other results from a google search for "SMACfdMain.exe aborted with system error code 3", I switched to a simpler problem detailed in the YouTube clip ABAQUS_CFD tutorial (https://www.youtube.com/watch?v=3VgkPbFvFmA). This resulted in the same error.

Finally I thought I would test a plain air space that had no objects in it so pure airflow and got the same error (see attached files for the model).

Is this an issue with the installation or v6.13 or something I am doing wrong ?

Thanks in advance,

Miten

aerofoil.cae
aerofoil.jnl
Reply | Threaded
Open this post in threaded view
|

Re: ABAQUS/CAE: FSI

ftastisch
This post has NOT been accepted by the mailing list yet.
In reply to this post by priyanshu
Hi priyanshu!

Thanks for your advice!

Positioning was the key! ;)
Reply | Threaded
Open this post in threaded view
|

Re: ABAQUS/CAE: FSI

priyanshu
This post has NOT been accepted by the mailing list yet.
Glad it helped !

Priyanshu Sharma 
ME-DESIGN, BITS PILANI, HYDERABAD
AP-500078


On Wed, Jul 30, 2014 at 11:54 AM, ftastisch [via Abaqus Users] <[hidden email]> wrote:
Hi priyanshu!

Thanks for your advice!

Positioning was the key! ;)


If you reply to this email, your message will be added to the discussion below:
http://abaqus-users.1086179.n5.nabble.com/ABAQUS-CAE-FSI-tp21070p21591.html
To unsubscribe from ABAQUS/CAE: FSI, click here.
NAML

Reply | Threaded
Open this post in threaded view
|

Re: ABAQUS/CAE: FSI

mitenp
Hi Priyanshu/"Ftastisch",

Unfortunately, in my case there is no solid at all so don't think its a positioning problem.

I've attached the updated cae files which detail a rectangular air space with a simple aerofoil in the middle. Boundary conditions are simple V1 at inlet, pressure is zero at outlet and no slip at surface. Top/Bottom edges same V1 and front/back V3 is set to zero.

aerofoil.cae
aerofoil.jnl

In v6.12, the mesh reaches a solution. In v6.13, using the cae files generated via v6.12, get the error code 3.

Was trying to model a FSI scenario however kept getting the error code in v6.13 hence tried a simpler scenario to try and see if it was a mesh size issue etc.

Any thoughts, could be an issue with the installation. What versions are you each running ?

Thanks,

Miten
Reply | Threaded
Open this post in threaded view
|

Re: ABAQUS/CAE: FSI

priyanshu
This post has NOT been accepted by the mailing list yet.

Instead of front and back..give Z symm boundary condition..
Tell if it helps

On 31-Jul-2014 10:37 AM, "mitenp [via Abaqus Users]" <[hidden email]> wrote:
Hi Priyanshu/"Ftastisch",

Unfortunately, in my case there is no solid at all so don't think its a positioning problem.

I've attached the updated cae files which detail a rectangular air space with a simple aerofoil in the middle. Boundary conditions are simple V1 at inlet, pressure is zero at outlet and no slip at surface. Top/Bottom edges same V1 and front/back V3 is set to zero.

aerofoil.cae
aerofoil.jnl

In v6.12, the mesh reaches a solution. In v6.13, using the cae files generated via v6.12, get the error code 3.

Was trying to model a FSI scenario however kept getting the error code in v6.13 hence tried a simpler scenario to try and see if it was a mesh size issue etc.

Any thoughts, could be an issue with the installation. What versions are you each running ?

Thanks,

Miten


If you reply to this email, your message will be added to the discussion below:
http://abaqus-users.1086179.n5.nabble.com/ABAQUS-CAE-FSI-tp21070p21597.html
To unsubscribe from ABAQUS/CAE: FSI, click here.
NAML
Reply | Threaded
Open this post in threaded view
|

Re: ABAQUS/CAE: FSI

mitenp
Hi All,

Turned out to be very simple. Version 6.13 doesn't like spaces in the directory name of where the data files are located. Once the spaces were taken out of the name, the solution ran successfully.

The spaces cause an issue for the messaging system between the modules which is used mainly for fluid simulations.

Abaqus support advises that its been resolved in v6.14.

Wish all problems had such a simple solution !

Miten
Reply | Threaded
Open this post in threaded view
|

Re: ABAQUS/CAE: FSI

priyanshu
This post has NOT been accepted by the mailing list yet.

Glad...even.i have learned this.!

On 01-Aug-2014 5:29 AM, "mitenp [via Abaqus Users]" <[hidden email]> wrote:
Hi All,

Turned out to be very simple. Version 6.13 doesn't like spaces in the directory name of where the data files are located. Once the spaces were taken out of the name, the solution ran successfully.

The spaces cause an issue for the messaging system between the modules which is used mainly for fluid simulations.

Abaqus support advises that its been resolved in v6.14.

Wish all problems had such a simple solution !

Miten


If you reply to this email, your message will be added to the discussion below:
http://abaqus-users.1086179.n5.nabble.com/ABAQUS-CAE-FSI-tp21070p21610.html
To unsubscribe from ABAQUS/CAE: FSI, click here.
NAML
Reply | Threaded
Open this post in threaded view
|

Re: ABAQUS/CAE: FSI

hamawandy
This post has NOT been accepted by the mailing list yet.
Dear Miten


Thanks for your advice , actually I solved the same problem by deleting the spaces in the working directory name .


Best regards

Nazim Nariman
Ehs
Reply | Threaded
Open this post in threaded view
|

Re: ABAQUS/CAE: FSI

Ehs
This post has NOT been accepted by the mailing list yet.
In reply to this post by mitenp
Error in connection to analysis
Error in job turning: The executable explicit.exe aborted with system error code 1073741819

I have this error. I use a subroutine
data check is successful but once i submit the job after packager completed it gives me this error immediately. This software is a shame for dassault  
Ehs
Reply | Threaded
Open this post in threaded view
|

Re: ABAQUS/CAE: FSI

Ehs
This post has NOT been accepted by the mailing list yet.
before that i used numbers and spaces in directory and it gave me this "error 3" i changed the folder name  and i run abaqus cae from abaqus command after entering to the path and now it gives me this . Its a total waste of money and energy and time . better to use ansys if you want to start
Reply | Threaded
Open this post in threaded view
|

Re: ABAQUS/CAE: FSI

Miao
This post has NOT been accepted by the mailing list yet.
In reply to this post by priyanshu
Hi Priyanshu,

I met the same problem. But I am not sure that what do you mean by 'positioning'? Is it the positions of the two models should follow certain rule? Thank you very much for your attention.